Jump to content
Il server del mese è
Visita la nostra nuova lista server!
  • 0
NightCrawler

Problema multicraft

Question

buonasera a tutti, avrei un problema con multicraft, ho di nuovo riaperto un server dopo un paio di mesi che non giocavo ed è da ieri che non riesco a farlo partire utilizzando il loader di fabric, vi allego il log del repair tool che ho runnato poco fa

Cita

25.08 03:19:10 [Multicraft] Server stopped
25.08 03:19:10 [Multicraft] Looks like a crash, check the server console. Return value: 2
25.08 03:19:10 [Multicraft] Not restarting server due to server file settings.
25.08 03:19:10 [Multicraft] Server shut down (starting)
25.08 03:19:10 [Server] INFO /usr/bin/python3: can't open file '/region-fixer/regionfixer.py': [Errno 2] No such file or directory
25.08 03:19:09 [Multicraft] Updating eula.txt file
25.08 03:19:09 [Multicraft] JAR file not found. Go to "Settings"-"Update Minecraft" to download the JAR file.
25.08 03:19:09 [Multicraft] Failed to copy jarfile from global JAR directory
25.08 03:19:09 [Multicraft] JAR file not found, copying from global JAR directory

questo è invece ciò che mi esce quando provo a startare il server:

Cita
  1.  
25.08 03:31:15 [Multicraft] Server stopped
25.08 03:31:15 [Multicraft] Looks like a crash, check the server console. Return value: 1
25.08 03:31:15 [Multicraft] Not restarting crashed server.
25.08 03:31:15 [Multicraft] Server shut down (starting)
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.util.sat4j.mini
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.util.sat4j.minisat.constraints.MixedDataStructureDanielWL.createClause(MixedDataStructureDanielWL.java:81) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.util.sat4j.minisat.constraints.cnf.Clauses.sanityCheck(Clauses.java:97) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.util.sat4j.minisat.constraints.cnf.Clauses.propagationCheck(Clauses.java:117) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO Caused by: net.fabricmc.loader.util.sat4j.specs.ContradictionException: Creating Empty clause ?
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.launch.server.FabricServerLauncher.main(FabricServerLauncher.java:56) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.launch.server.FabricServerLauncher.setup(FabricServerLauncher.java:114) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.launch.server.FabricServerLauncher.launch(FabricServerLauncher.java:68) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_281]
25.08 03:31:15 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_281]
25.08 03:31:15 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_281]
25.08 03:31:15 [Server] INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_281]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.launch.knot.KnotServer.main(KnotServer.java:28) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.launch.knot.Knot.init(Knot.java:132) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.FabricLoader.load(FabricLoader.java:185) [fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.FabricLoader.setup(FabricLoader.java:195) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.discovery.ModResolver.resolve(ModResolver.java:832) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO at net.fabricmc.loader.discovery.ModResolver.findCompatibleSet(ModResolver.java:198) ~[fabric-server-launch.jar:?]
25.08 03:31:15 [Server] INFO net.fabricmc.loader.discovery.ModResolutionException: Could not find required mod: minecraft requires {java @ [>=16]}
25.08 03:31:15 [Server] main/FATAL A critical error occurred
25.08 03:31:14 [Server] main/INFO Loading for game Minecraft 1.17.1
25.08 03:31:13 [Server] INFO Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512M; support was removed in 8.0
25.08 03:31:13 [Server] INFO Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
25.08 03:31:12 [Multicraft] Updating eula.txt file
25.08 03:31:12 [Multicraft] Loaded config for "Default"
25.08 03:31:12 [Multicraft] Starting server!

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

devi installara java 16, se sei su ubuntu basta fare

apt install openjdk-16-jre

sudo update-alternatives --config java
e selezioni il numero senza il *davanti

Share this post


Link to post
Share on other sites
  • 0
2 ore fa, Xxluca_wolfxX dice:

devi installara java 16, se sei su ubuntu basta fare

apt install openjdk-16-jre

sudo update-alternatives --config java
e selezioni il numero senza il *davanti

ho installato java 16 sul pc, ma il problema è che il server in se parte, quando lo faccio partire normalmente con il file jar di minecraft 1.17.1 vanilla, ma se lo faccio partire dal file jar di fabric mi da questo problema, quindi ho immaginato di dover inserire java su filezilla in qualche cartella o direttamente su multicraft, ma non so dove esattamente devo inserirlo 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.