Jump to content
  • 0
Xyroh

Problema con un server [RISOLTO]

Question

Salve, io e due amici vorremmo creare un server con dei datapack, ma il server non va.

abbiamo provato a togliere i datapack, a togliere il firewall, ad aprire le porte del router, ma appena entro non mi fa fare e dopo qualche secondo mi fa crashare dicendo "disconnected".

Non sono io l'host ma il mio amico che hosta si è arreso. abbiamo addiritturo provato con siti come aternos ma niente

Edited by MasterMatte27

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

ENORME AGGIORNAMENTO, chi hosta il server usa connessione wireless, e quando entro se rompo dei blocchi, se dopo rientro a volte sono sono rotti veramente, quindi il problema è il wifi del mio amico

EDIT

hosterà un altro amico quindi potete chiudere la conversazione

Share this post


Link to post
Share on other sites
  • 0
40 minuti fa, Xyroh dice:

Salve, io e due amici vorremmo creare un server con dei datapack, ma il server non va.

abbiamo provato a togliere i datapack, a togliere il firewall, ad aprire le porte del router, ma appena entro non mi fa fare e dopo qualche secondo mi fa crashare dicendo "disconnected".

Non sono io l'host ma il mio amico che hosta si è arreso. abbiamo addiritturo provato con siti come aternos ma niente

dove hostate il server, che cosa avete sopra?

datemi piu info possibili

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 minuti fa, MasterMatte27 dice:

dove hostate il server, che cosa avete sopra?

datemi piu info possibili

Hostiamo sul PC di uno dei due miei amici, abbiamo provato con server vanilla o bukkit ma non va lo stesso

Share this post


Link to post
Share on other sites
  • 0
1 minuto fa, Xyroh dice:

Hostiamo sul PC di uno dei due miei amici, abbiamo provato con server vanilla o bukkit ma non va lo stesso

vi ho chiesto delle info, per esempio: ha aperto le porte del router?

avete la versione giusta?

che errore ti esce?

 

vi consiglio vivamente di comprarlo da host a 2 euro risparmiando sta trafila

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 minuto fa, MasterMatte27 dice:

vi ho chiesto delle info, per esempio: ha aperto le porte del router?

avete la versione giusta?

che errore ti esce?

 

vi consiglio vivamente di comprarlo da host a 2 euro risparmiando sta trafila

Si le porte sono aperte, usiamo 1.16.1 ma appena entro non vedo chat, se rompo blocchi non stoppa nulla e poi crasho con il messaggio"Disconnected"

6 minuti fa, MasterMatte27 dice:

 

 

Share this post


Link to post
Share on other sites
  • 0
1 minuto fa, Xyroh dice:

Si le porte sono aperte, usiamo 1.16.1 ma appena entro non vedo chat, se rompo blocchi non stoppa nulla e poi crasho con il messaggio"Disconnected"

 

è un problema tuo allora se agli altri funziona... quanta ram è dedicata?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Circa 4giga

Adesso, MasterMatte27 dice:

è un problema tuo allora se agli altri funziona... quanta ram è dedicata?

 

Share this post


Link to post
Share on other sites
  • 0

Non credo che con 3 euro reggano 34 datapack

Share this post


Link to post
Share on other sites
  • 0
1 minuto fa, MasterMatte27 dice:

allora non è ram, solo a te da questo?

No, anche all'altro che vuole entrare

Share this post


Link to post
Share on other sites
  • 0
Adesso, Xyroh dice:

Non credo che con 3 euro reggano 34 datapack

non so, ma se non mi fornisci altre informazioni non saprei, disconnected capita quando non hai internet o altro di solito o quando si spegne il server di botto,

succede solo a te?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 minuti fa, MasterMatte27 dice:

allora non è ram, solo a te da questo?

No, anche all'altro che vuole entrare

Share this post


Link to post
Share on other sites
  • 0

Non ho io la console, ma proverò a farmeli inviare

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
12 minuti fa, Xyroh dice:

Non ho io la console, ma proverò a farmeli inviare

perfetto, cosi risolviamo

ti invito a valutare il mio operato con un like ai messaggi☺️

  • Like 2

Share this post


Link to post
Share on other sites
  • 0
8 minuti fa, MasterMatte27 dice:

siete premium?

il server si è spento subito dopo?

Siamo due premium e un sp, il server continua ad andare ma con o senza online mode non cambia niente

Share this post


Link to post
Share on other sites
  • 0
36 minuti fa, Xyroh dice:

Siamo due premium e un sp, il server continua ad andare ma con o senza online mode non cambia niente

il problema sono dei teletrasporti alle le prime righe del log, controllate quei comandi che vengono generati

[10:06:30] [main/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[10:06:30] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[10:06:30] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[10:06:30] [main/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[10:06:30] [main/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]

quando uno entra viene teletrasportato tante volte e poi crasha

Share this post


Link to post
Share on other sites
  • 0

Oh, non si perché ma vedrò

Una qualche idea del motivo?

Edited by Reaches

Share this post


Link to post
Share on other sites
  • 0

Perdonate se mi intrometto ma a me sembra che quelli siano più degli errori dovuti a dei valori errati inseriti in qualche configurazione. Anche perché il giocatore entra molto dopo a questa stringa..

[10:08:39] [User Authenticator #1/INFO]: UUID of player zXyroh is 2f393dd7-021d-401a-a7ea-5f2b58659db6
[10:08:39] [Server thread/INFO]: zXyroh[/ip] logged in with entity id 201 at (-199.5, 65.0, -181.5)

Potresti controllare anche i log di minecraft, magari è presente qualche altra informazione. Comunque avrei una domanda, sono tutti datapacks scaricati?? Perché potrebbe essere un errore di scrittura del codice, magari nel datapack che ascolta l'evento dell'entrata del giocatore, per eseguire qualche azione (che potrebbe essere quel teleport, che da errore). Non so la butto lì ma mi sembra una ricostruzione abbastanza verosimile di quello che potrebbe accadere.   

Edited by Reaches

Share this post


Link to post
Share on other sites
  • 0
1 minuto fa, Reaches dice:

Perdonate se mi intrometto ma a me sembra che quelli siano più degli errori dovuti a dei valori errati inseriti in qualche configurazione. Anche perché il giocatore entra molto dopo a questa stringa..


[10:08:39] [User Authenticator #1/INFO]: UUID of player zXyroh is 2f393dd7-021d-401a-a7ea-5f2b58659db6
[10:08:39] [Server thread/INFO]: zXyroh[/ip] logged in with entity id 201 at (-199.5, 65.0, -181.5)

Potresti controllare anche i log di minecraft, magari è presente qualche altra informazione. Comunque avrei una domanda, sono tutti datapacks scaricati?? Perché potrebbe essere un errore di scrittura del codice, magari nel datapack che ascolta l'evento dell'entrata del giocatore, per eseguire qualche azione (che potrebbe essere quel teleport, che da errore). Non so la butto lì ma mi sembra una ricostruzione abbastanza verosimile di quello che potrebbe accadere.   

Non disturbi tranquillo, abbiamo provato con e senza datapack, ma l'errore è lo stesso

Share this post


Link to post
Share on other sites
  • 0

Stavo notando anche la presenza di un errore prima che il server inizi il caricamento dei mondi, il che mi fa pensare a qualche scrittura errata nel file server.properties o qualcosa di simile.
Anche se penso si noti, l'errore è questo.

[Server console handler/ERROR]: Exception handling console input
java.io.IOException: Handle non valido
	at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_211]
	at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_211]
	at java.io.BufferedInputStream.read1(Unknown Source) ~[?:1.8.0_211]
	at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_211]
	at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_211]
	at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_211]
	at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_211]
	at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_211]
	at java.io.BufferedReader.fill(Unknown Source) ~[?:1.8.0_211]
	at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_211]
	at java.io.BufferedReader.readLine(Unknown Source) ~[?:1.8.0_211]
	at yd$1.run(SourceFile:90) [server.jar:?]

Soltanto che non mi viene in mente una causa precisa se non quella detta prima. Prova a controllare anche lì, dato che ormai stiamo escludendo i datapacks visto che anche senza il problema persiste. 

EDIT: 

Aggiungo anche che sarebbe da vedere se il server si spegne anche senza entrare, oppure rimane attivo.

[10:09:06] [Server thread/INFO]: zXyroh lost connection: Timed out
[10:09:06] [Server thread/INFO]: zXyroh left the game
[10:09:37] [Server thread/INFO]: Stopping the server
[10:09:37] [Server thread/INFO]: Stopping server
[10:09:37] [Server thread/INFO]: Saving players
[10:09:37] [Server thread/INFO]: Saving worlds
[10:09:37] [Server thread/INFO]: Saving chunks for level 'ServerLevel[world]'/minecraft:overworld
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (world): All chunks are saved
[10:09:38] [Server thread/INFO]: Saving chunks for level 'ServerLevel[world]'/minecraft:the_nether
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM-1): All chunks are saved
[10:09:38] [Server thread/INFO]: Saving chunks for level 'ServerLevel[world]'/minecraft:the_end
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM1): All chunks are saved
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (world): All chunks are saved
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM-1): All chunks are saved
[10:09:38] [Server thread/INFO]: ThreadedAnvilChunkStorage (DIM1): All chunks are saved

Perché stando a quanto riportato, sembrerebbe che dopo che il giocatore faccia "timed out" il server inizia a stopparsi e non mi sembra neanche di aver letto che è stato eseguito il comando quindi è una cosa interna. Il tutto ora mi viene in mente, riporterebbe alla mia ipotesi di prima dove provavo a capire a cosa si riferisse il primo errore in alto, avendo come conclusione un possibile codice scritto male in qualche datapacks. 

Edited by Reaches

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.